Android:ERROR: Failed to resolve: com.android.support:support-v4:19.1.0

更新时间: 2019/8/16 9:47:55     点击率: 1966
原因分析和解决
support annotations自25.4.0之后support包不在sdk中更新了,需要用谷歌的maven库,在Project的build.gradle中添加如下谷歌的地址,因此需要我们手动的在Project的build.gradle中添加如下谷歌的地址:

allprojects {
  repositories {
    ...
    //需要添加的部分,两个仓库添加其一即可解决  
    maven { url "https://maven.google.com"}
    maven { url "https://dl.google.com/dl/android/maven2/"}
    ...
  }
}

这样异常就完美解决了。